Blog Stats
  • Posts - 171
  • Articles - 1
  • Comments - 197
  • Trackbacks - 4

 

lunedì 14 marzo 2011

Jquery 1.5 $.ajax and jquery validator issue

La nuova release di jquery, la 1.5, ha portato novità in particolare per quanto riguarda la gestione delle chiamate ajax tramite la funzione $.ajax.

Per queste rimando alla documentazione ufficiale.

Se pero’ utilizzate la 1.5 insieme al plugin di validazione jquery.validate (che per esempio è quella che viene aggiunta di default quando si crea un progetto MVC 3), si verificherà sempre un errore se nella chiamata ajax specificate il dataType = ‘json’.

In pratica tratta la chiamata per “json” come fosse un “jsonp”.
Qui la segnalazione http://bugs.jquery.com/ticket/8118#no1

La soluzione è scaricare l’aggiornamento della jquery.validate da qui:
https://github.com/jzaefferer/jquery-validation/issues/36

del.icio.us Tags: ,

 

 

Copyright © Luca Mauri