Reporting Services 2008 e wss 3.0

Giusto perchè ci ho perso speso una nottata più una mattina su questa cosa, la scrivo qui anche se non riguarda le ultime tennologie.

Il problema è che continuavo a ricevere questo errore:

 

The feature: "Windows SharePoint Services integration" is not supported in this edition of Reporting Services. (rsOperationNotSupported)

 

quando tentavo di accedere al mio reporting server URL, dopo aver configurato il tutto. Per essere sicuro che avessi fatto tutto correttamente (per la serie, “non si sa mai”) ho anche creato una nuova VM seguendo questa ottima guida.

Ma ciò nonostante ricevevo sempre lo stesso errore.

Ho cominciato ad indagare su vari problemi di compatibilità tra le varie permutazioni di versioni ed edizioni sia di sharepoint, sharepoint services e sql.

Se la memoria di calcolo combinatorio non mi inganna stiamo parlando di: 3 edizioni di MOSS 2007 (senza SP, con SP1 e con SP2), 3 di sharepoint services (idem come prima), e diciamo ALMENO 2 edizioni di SQL Server per ogni versione (più relativi SP): sql server 2005 express, sql server 2005 standard (o più), sql server 2008 express, sql server 2008 standard (o più), questi ultimi anche con il SP2.
Non parliamo della versione R2, e non parliamo se *dovesse* centrare la versione del sistema operativo…

E’ chiaro anche a voi che tutte le combinazioni non erano testabili prima che l’umanità non colonizzi completamente il sistema Solare ed il vicino Alpha Centauri, per cui dovevo darmi da fare per non spendere altre 4 ore…

Dopo aver letto con interesse la tabella di compatibilità tra versioni di SQL Server e SharePoint, ancora la cosa non mi quadrava: sembrava che tutto dovesse funzionare.

Allora ho deciso di puntare su MSDN, la sua media scarsa rilevanza me la fa mettere sempre come ultima spiaggia, ma questa volta una frase utile l’ho trovata su questa pagina:

“Edition requirements for Reporting Services in SharePoint integrated mode include Developer, Evaluation, Standard, or Enterprise editions. There is no support for this feature in the Workgroup edition or in SQL Server Express with Advanced Services.”

Ho installato quindi la versione Standard di SQL Server (2008) ed ha funzionato tutto alla perfezione.

Print | posted @ Wednesday, January 5, 2011 3:57 PM

Comments on this entry:

No comments posted yet.

Your comment:

Title:
Name:
Email:
Website:
 
Italic Underline Blockquote Hyperlink
 
 
Please add 6 and 7 and type the answer here: