SubText e ASP.NET 2.0

Ultimamente mi è arrivata una mail di un utente che aveva installato l'ultima versione stabile di SubText (la 1.5.2), ma il suo blog aveva uno strano comportamento: l'admin funzionava, tutte le pagina funzionavano, ma non andava la default.aspx.

Contemporaneamente sul bugtracker di SF.net un altro utente aveva lo stesso identico problema ... e Phil mi ha detto di aver ricevuto alcune mail di altri utenti, sempre con lo stesso problema.

Alla fine il problema era che tutti avevano installato SubText 1.5.* in una web application con ASP.NET 2.0. Questa versione di ST non può funzionare sulla 2.0 per via delle svariate breaking changes introdotte nel motore di ASP.NET.

L'unica versione che funziona con ASP.NET 2.0 sarà la 1.9, che però non è ancora stata rilasciata.
Quindi, o installate la 1.5.2 su ASP.NET 1.1, o vi "arrischiate" a installare una delle ultime integrations della 1.9 su ASP.NET 2.0.
Mio consiglio: se fossi in voi aspetterei qualche settimana e installarei la 1.9 final: oltre al porting verso ASP.NET 2.0 sono state aggiunte delle funzionalità interessanti come la moderazione dei commenti, supporto completo dei gravatars (ora è abilitato di default su tutte le skin standard) e svariati bug-fixing.

powered by IMHO 1.3

posted @ martedì 1 agosto 2006 10:15

Print
Comments have been closed on this topic.
«dicembre»
domlunmarmergiovensab
27282930123
45678910
11121314151617
18192021222324
25262728293031
1234567