SharePoint 2010 - Errore in User Profile Service Application

Può capitare che, dopo aver avviato il servizio “User Profile Synchronization Service” di SharePoint 2010, se andiamo a cliccare su “User Profile Service Application” ci viene restituito un errore di questo genere:

UserProfileServiceUserStatisticsWebPart:LoadControl failed, Exception: System.IO.FileLoadException:

The located assembly's manifest definition does not match the assembly reference.

(Exception from HRESULT: 0x80131040)     at Microsoft.Office.Server.UserProfiles.UserProfileConfigManager.InitializeIlmClient(String ILMMachineName, Int32 FIMWebClientTimeOut)     at Microsoft.Office.Server.UserProfiles.UserProfileConfigManager..ctor(UserProfileApplicationProxy userProfileApplicationProxy, Guid partitionID)     at Microsoft.SharePoint.Portal.WebControls.UserProfileServiceStatisticsWebPartBase.LoadControl(Object sender, EventArgs e) 

 

La soluzione è abbastanza semplice, anche se ci può far perdere un po’ di tempo: dipende dal fatto che, come indicato in questo articolo Technet, se la “Central Administration” e il servizio “User Profile Synchronization Service” risiedono sullo stesso server, è necessario effettuare un IISReset dopo l’avvio del servizio.

Una volta effettuato il nostro IISReset, tutto ricomincia a funzionare correttamente.

Technorati Tags:

posted @ lunedì 26 luglio 2010 15:53

Print
Comments have been closed on this topic.
«ottobre»
domlunmarmergiovensab
262728293012
3456789
10111213141516
17181920212223
24252627282930
31123456