Sembrava fosse un bug invece...

Vi ricordate dove parlavo di un preseunto bug nel Databind di classi personalizzate? oggi parlando con AndreaS - anche lui tempo prima aveva avuto a che fare con lo stesso problema - mi ha fatto notare che non è un bug... ma il tutto è documentato. Dove dico io? MSDN - System.Windows.Forms.DataGrid

"You can also bind the DataGrid to an ArrayList. A feature of the ArrayList is that it can contain objects of multiple types, but the DataGrid can only bind to such a list when all items in the list are of the same type as the first item. This means that all objects must either be of the same type, or they must inherit from the same class as the first item in the list." - che poi è quello che mi diceva Bini :p

Arg... ma come possibile che non l'abbia letto mi sono chiesto, semplice io avevo avuto il problema su Web e avevo dunque limitato la mia ricerca a System.Web.UI.WebControls.DataGrid, dove la cosa non sembra essere documentata - a questo punto spero di avere visto bene ;p

beh NON sarà un bug MA il problema sussiste... quindi le osservazioni (alcune a questo punto sono un po come la scoperta dell'acqua calda) ma soprattutto i workaround fatti/proposti sul forum sono ancora validi, per chi fosse interessato questo è il therad completo: http://www.ugidotnet.org/forum/thread.asp?m=23452 ;p

posted @ giovedì 6 novembre 2003 00:20

Print
Comments have been closed on this topic.
«novembre»
domlunmarmergiovensab
31123456
78910111213
14151617181920
21222324252627
2829301234
567891011